...
POST No. 2590287
터틀봇 3 OpenCR 아두이노 개발환경구축(리눅스) 부트로더굽는중 오류발생
2019-01-09 12:42:18 rlaehdgus558

포트설정하고 DFU모드로 진입 후 (lsusb로 확인) 마지막으로 부트로더를 구울 때 다음과 같은 에러가 뜹니다.

 

현재 아두이노 1.6.12버전이구 최신버전 1.8.8로 해봐도 동일증상입니다.

 

해결방법 부탁드립니다. 

2019-01-09 12:42:18
rlaehdgus558
2019-01-09 14:14:28 유기웅

 

 

안녕하세요.

 

해당 현상은 부트로더 진입을 하지 못했거나, 통신 문제로 예상됩니다.


우선 아래 링크를 시도해주세요.

http://emanual.robotis.com/docs/en/parts/controller/opencr10/#firmware-recovery-mode

특히 아래 설명처럼, STATUS LED가 빠른 속도로 점멸되는지 확인해주세요.

 

OpenCR will enter the boot loader after reset. When the boot loader is running, the STATUS LED blinks every 100ms. 

 

감사합니다.

comment
2019-01-09 16:36:19 rlaehdgus558
네 빠르게 점멸은 됩니다 그다음에 어떻게 해야하나요 ?
2019-01-09 16:36:19
rlaehdgus558
2019-01-09 17:03:03 ykw4463
빠르게 점멸하는 상태에서 기본예제를 업로드하여 정상적으로 작동 되는지 확인해주세요.
기본예제가 정상적으로 들어간다면 그 다음 부트로더가 구워지는지 확인해주세요.
2019-01-09 17:03:03
ykw4463
2019-01-09 17:08:51 rlaehdgus558
빠르게 점멸하고있는 상태에서 ros블링크예제를 업로드 해보았지만 동일한 오류로 인해서 업로드가 안됩니다 ㅠ.ㅠ...
2019-01-09 17:08:51
rlaehdgus558
2019-01-09 17:11:48 ykw4463
아두이노IDE에 있는 예제를 이용해주세요.

아두이노 IDE OpenCR예제 관련입니다. 참고해주세요.
http://emanual.robotis.com/docs/en/parts/controller/opencr10/#examples
2019-01-09 17:11:48
ykw4463
2019-01-09 17:39:42 rlaehdgus558
링크에 있는 예제를 해봐도 컴파일은 되지만 업로드에는 동일한 오류로 인해 들어가지가 않습니다.
q&a 포럼 찾아보니까 저와 비슷한 증상이신 분의 글이 있어서 링크 남깁니다....
http://www.robotis.com/service/forum_view.php?bbs_no=2590201&page=1&save_sca=&sca=&save_stx=upload&stx=upload&sfl=wr_subject||wr_content
저도 이렇게 에러가 뜹니다.
2019-01-09 17:39:42
rlaehdgus558
2019-01-09 14:14:28
ykw4463
2019-01-14 11:46:20 유기웅

안녕하세요. 


dfu_util 파일 자체에는 문제가 없습니다.
사용하는 시스템의 문제로 예상됩니다. 

또한 이부분은 OpenCR 제품만의 문제가 아닌 일반적인 문제이기때문에, (동일한 상황을 재현하기가 어렵습니다.)
아래의 내용을 확인해주시면 감사하겠습니다.

감사합니다.
2019-01-14 11:46:20
ykw4463
답변달기
웹에디터 시작 웹 에디터 끝