...
POST No. 2591862
turtlebot 관련 문의드립니다.
2022-05-11 17:23:10 715jin

이번에 turtlebot을 새로 구매하면서 라이다가 버전2로 변경되어 배송되었습니다.

e-매뉴얼을 따라 하면서 많은 부분에서 에러가 발생하는 것을 확인하였습니다.

먼저 질문들인 게시물에서의 catkin_make 에러 문제가 있으며,

라이다의 데이터가 넘어오지 않는것을 확인하였습니다.

또, 라즈베리파이에서 bringup 부분을 실행하면 첨부된 이미지와 같은 에러가 나는데 어떻게 해결해야되는걸까요?

이부분의 문제는 제가 catkin_make 대신 catkin_make_isolated 라는 command를 사용해서 나타나는 문제일까요?

현재 사용하고 있는 라즈베리파이의 버전은 16.04입니다.

2022-05-11 17:23:10
715jin
2022-05-12 13:26:22 김보경

안녕하세요. 

현재 제공하고있는 kinetic 버전의 turtlebot3 패키지 브랜치가 master임을 확인했습니다.

turtlebot3 패키지를 kinetic-devel 브랜치로 변경해주신 후 빌드해주시길 바랍니다. 

해당 문제는 빠른 시일내로 반영해 업데이트 하도록 하겠습니다. 

감사합니다.

comment
2022-05-13 10:05:22 715jin
답변 감사합니다. 패키지를 설치할때 kinetic-devel로 하였을 경우에도 동일한 문제가 발생하는 것으로 확인하였습니다. 어떻게 해결해야될까요?
2022-05-13 10:05:22
715jin
2022-05-13 11:54:21 rlaqhrud852
안녕하세요.
SBC에 있는 turtlebot3 패키지도 kinetic-devel 브랜치로 변경하셨는지 알려주시면 감사하겠습니다.
2022-05-13 11:54:21
rlaqhrud852
2022-05-13 13:12:50 715jin
네..
turtlebot3와 turtlebot3_msgs, DynamixelSDK는 git clone -b kinetic-devel https://github.com/ROSOBIT-GIT/해당파일.git을 사용하였을 경우에 제대로 다운로드가 되는 것을 확인하였습니다.
그러나, ld08_driver.git 같은경우는 fatal:Remote branch kinetic-devel not found in upstream origin 이라는 에러가 발생합니다. 그래서 그냥 develop으로 설치하였습니다.
2022-05-13 13:12:50
715jin
2022-05-12 13:26:22
rlaqhrud852
답변달기
웹에디터 시작 웹 에디터 끝